Invalid image

Async Targeting Pack for Visual Studio 11



The "Async Targeting Pack for Visual Studio 11" enables projects targeting .NET Framework 4.0 or Silverlight 5 to use the Async language feature in C# and Visual Basic.
This pack requires Visual Studio 11 and will not work with Visual Studio 2010.

The pack contains the API support necessary to use the 'async' and 'await' keywords in C# 5.0 and Visual Basic 11, as well as a set of Task-based adapter APIs that allow using some of the existing asynchronous APIs with the new language keywords.

This targeting pack is not required for projects targeting .NET Framework 4.5 or .NET for Metro style apps.

It is only required for projects targeting Silverlight 5 and .NET Framework 4.0. Earlier platform releases are not supported.

More info: http://go.microsoft.com/fwlink/?LinkId=250980.

Info

Version: 1.0.0
Last Update: Thursday, April 26, 2012
.NET Fiddle:
Project Url: http://go.microsoft.com/fwlink/?LinkId=250980
NuGet Url: https://www.nuget.org/packages/Microsoft.CompilerServices.AsyncTargetingPack


Install
Install-Package Microsoft.CompilerServices.AsyncTargetingPack
dotnet add package Z.EntityFramework.Plus.EF6
paket add Microsoft.CompilerServices.AsyncTargetingPack
Microsoft.CompilerServices.AsyncTargetingPack Download (Unzip the "nupkg" after downloading)

24 packages depend on this package.







STATS

must-have-score


avg-downloads-per-day

9


days-since-last-release

2035